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Notebook is a text editor.    It is nimble, feature-rich and effectively bullet-proof.    For site and
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File Menu

The File menu includes commands to establish new workspace, to enable file open, save, 
delete, combine and run, and to print.

New Begins a new file.
Open Opens an existing file.
Save Saves the current document.
Save As Names the current document.
Backup Creates a backup document upon file save.
Delete Allows selection of files for deletion.
Merge Inserts a file anywhere in a document.
Run Starts an application and can open a document.
Printer Setup Allows printer selection and driver setup.
Margins Sets the formatting of the printed document.
Print All Prints the entire document.
Print Selection Prints selected text of the current document.
Exit Allows exit from Notebook.
Open History Opens one of the last four files opened.



Edit Menu

The Edit menu includes commands to undo the previous edit or file merge operation, to 
move text to and from the clipboard, and to format the edit control.

Undo Cancels a previous operation.
Cut Deletes text and moves it to the clipboard.
Copy Copies text to the clipboard.
Paste Inserts text from the clipboard into the document.
Delete Deletes text without moving it to the clipboard.
Select All Selects all text of a document.
Word Wrap Wraps text of a document.
Page Break Inserts a page break.
Control Code Allows editing of control code.
Initial Size Sets the initial size and position of the window.
Set Width Sets window width to printer page width.
Fonts Selects the screen font, tab spacing and characters per line.
Set Case Allows setting the case of the selected text.
Date Inserts the date into the document.
Time Inserts the time into the document.
Long Date Inserts unabridged date into the document.
Date Format Sets date and time format.



Search Menu

The Search menu includes commands to enable go to a line, and/or to find the next or 
previous iteration of a text string, or to replace one or all occurrences of a text string.

Go To Allows line number, search and replace string entry.
Find Next Searches for the next occurrence of the search string.
Find Prev Searches for the previous occurrence of the search string.
Replace Replaces selected text with the replace string.
Replace All Replaces all occurrences of the search string with the replace string.
Set Find Copies selected text from the edit window to the search string buffer.
Set Replace Copies selected text from the main edit window to the replace string 

buffer.
Dialog Mode Allows Go To dialog to be destroyed after a successful search.
Bookmark Sets a bookmark position.
Position Displays the line number and document size information.



Push Button Menu Items

Push button menu items are the right aligned buttons on the menu bar.    The vertical scroll 
bar range is limited to the current page or field.    Notebook has a nominal field size of 32 
thousand bytes.    When scrolling through a document from one field    to the next is possible,
an arrow on at least one of the menu bar buttons is shown darkened.    A mouse click on the 
bitmap is used as the command to show the next or previous field.    Keyboard scrolling is 
done with the CTRL+PGUP or CTRL+PGDN key combinations.    The overlap between fields is 
one line.

Field Scroll Down Scrolls to the next field.
Field Scroll Up Scrolls to the previous field.



File New Command

The New command clears the edit window and document name.

See...
Creating New Documents.



File Open Command

The Open command allows reading the selected file into memory for display and editing.

See...
Opening an Existing File.



File Save Command

The Save command writes the current named document to disk .

See...
Saving Documents.



File Save As Command

The Save As command allows naming or renaming the document which then may be saved.

See...
Saving Documents.



File Backup Command

The Backup command allows the creation of a backup file when the document is saved the 
first time after the original file is opened.

See...
Backing Up a Text File.



File Delete Command

The Delete command allows the selection of up to sixteen files at a time for deletion.

See...
Deleting Files.



File Merge Command

The Merge command allows the insertion of a file into the document at the current caret 
position.

See...
Merging a File.



File Run Command

The Run command allows the execution of an application and optionally the opening of an 
associated file.

See...
Running an Application.



File Printer Setup Command

The Printer Setup command allows default printer selection and printer driver setup.

See...
Setting Printers.



File Margins Command

The Margins command can set margin sizes and enable title, page numbers, page breaks, 
and two-sided page format output to the printed document.

See...
Inserting a Page Break.
Setting Margins



File Print All Command

The Print All command sends the entire document to the print spooler.

See...
Printing a Document.



File Print Selection Command

The Print Selection command sends selected text of the document to the print spooler.

See...
Printing Selected Text.



File Exit Command

The Exit command allows an exit from Notebook.    A message box is answered if changes 
were made.



File Open History Command

The Open History command reveals a cascade menu to show filenames of the last four files 
that were opened.    Select any of these files to be opened.

See...
Opening an Existing File.



Edit Undo Command

The Undo command allows the previous edit or file merge to be undone.

See...
Undoing Edits.



Edit Cut Command

The Cut command removes selected text sending the text to the clipboard.

See...
Copying, Cutting and Pasting.



Edit Copy Command

The Copy command sends selected text to the clipboard.

See...
Copying, Cutting and Pasting.



Edit Paste Command

The Paste command inserts clipboard text into the document.

See...
Copying, Cutting and Pasting.



Edit Delete Command

The Delete command removes selected text from the document.

See...
Deleting Text.



Edit Select All Command

The Select All command selects the entire document for any editing purpose.

See...
Selecting Text.



Edit Word Wrap Command

The Word Wrap command allows the text of the edit control to be wrapped.

See...
Wrapping Text.



Edit Page Break Command

The Page Break command inserts a page break into the document at the caret.

See...
Inserting    a Page Break.



Edit Control Code Command

The Control Code command translates unprintable control codes into printable characters to 
allow editing.

See...
Editing Control Codes.



Edit Initial Size Command

The Initial Size command sets the beginning size and position of the main window.

See...
Setting Initial Window Size.



Edit Set Width Command

The Set Width command sets the edit window width to the printer page width.

See...
Setting Window Width.



Edit Fonts Command

The Fonts command allows selection of font, tab-stop spacing and characters per line.    The 
OEM font has unique characters to display control codes.

See...
Editing Control Codes
Selecting a Screen Font
Setting Tab Spacing.
Setting Window Width.



Edit Set Case Command

The Set Case command reveals a cascade menu to allow setting the case of selected text in 
four ways.

See...
Selecting Text
Setting Case.



Edit Date Command

The Date command inserts the date in selected format into the document.

 See...
Inserting Date and Time.



Edit Time Command

The Time command inserts the time in selected format into the document.

See...
Inserting Date and Time.



Edit Long Date Command

The Long Date command inserts the unabridged date in selected format into the document.

 See...
Inserting Date and Time.



Edit Date Format Command

The Date Format command reveals a cascade menu to set the date and time format.    This 
menu also allows date and time to show in the title bar.

See...
Inserting Date and Time
Showing Date and Time.



Search Go To Command

The Go To command shows a modeless dialog box to enter find text, replace text or a line 
number.    The dialog box has push button controls to allow find next, find previous, replace, 
go to a bookmark and go to end functions.

See...
Finding Text
Going To a Line.



Search Find Next Command

The Find Next command continues a search for text in the forward direction.

See...
Finding Text.



Search Find Prev Command

The Find Prev command continues a search for text in the backward direction.

See...
Finding Text.



Search Replace Command

The Replace command replaces selected text with text from the replace string buffer.

See...
Replacing Text.



Search Replace All Command

The Replace All command replaces all occurrences of the search string text with text from 
the replace string buffer.

See...
Replacing Text.



Search Set Find Command

The Set Find command copies selected text from the edit window to the find string text 
buffer.    The first 63 characters of a selection will fill the buffer.    The buffer is truncated at 
any control character except horizontal tab.

See...
Finding Text.



Search Set Replace Command

The Set Replace command copies selected text from the edit window to the replace string 
text buffer.    The first 63 characters of a selection will fill the buffer.    The buffer is truncated 
at any control character except horizontal tab.

See...
Replacing Text.



Search Dialog Mode Command

The Dialog Mode command determines whether the Go To dialog box is destroyed after a 
successful search.

See...
Setting Go To Dialog Mode.



Search Bookmark Command

The Bookmark command uses the caret position to set a document bookmark.

See...
Using the Bookmark.



Search Position Command

The Position command shows a modeless dialog box to display current line and document 
size.

See...
Determining File Size.



Field Scroll Down

The Field Scroll Down push button is inscribed with a down arrow.    The command will show 
the first page of the next field of the document in the edit window.

See...
Determining File Size
Formatting Text.



Field Scroll Up

The Field Scroll Up push button is inscribed with an up arrow.    The command will show the 
first page of the previous field of the document in the edit window.

See...
Determining File Size
Formatting Text.



Backing Up a Text File

1. Select unchecked Backup from the File menu.
2. A backup file is created when an opened file is saved for the first time.    The backup file 

will get the extension "bak".
3. Select the checked Backup from the File menu to disable backup file creation.
4. Notebook.ini holds the Backup status.



Copying, Cutting and Pasting Text

Copy, Cut and Paste selected from the Edit menu use the clipboard.

Copy
1. Select text from the edit window.
2. Select Copy from the Edit menu.

The selected text is copied to the clipboard.    The text remains selected.

Cut
1. Select text from the edit window.
2. Select Cut from the Edit menu.

The selected text is removed from the edit window and copied to the clipboard.

Paste
1. Text is copied to the clipboard.
2. Select Paste from the Edit menu.

The clipboard contents are inserted at the current caret position.



Creating New Documents

1. Select New from the File menu.
2. If there are changes to be saved then answer the message box.    The edit window is 

cleared, and the document will be "untitled".



Deleting Files

1. Select Delete from the File menu to show the dialog box.
2. The file extension list box can quickly set the filespec for the files list box.
3. Select from one to sixteen files from the extended selection list box.    Or type the 

appropriate text into the edit control.
4. Select Delete.

A Confirmation message box is shown to allow one final chance at not deleting each of 
the choices made in the dialog box.



Deleting Text

1. Select the text to be removed.
2. Select Delete from the Edit menu.

The selected text is removed from the edit window.

See...
Notebook Keys.



Determining File Size

1. Select unchecked Position from the Search menu.
2. The modeless dialog box is displayed to the left of the title bar and menu bar buttons.

The two values shown in the box are current line and document size.    The line value is 
the line number of the current caret position.    The size value is the number of bytes in 
the document.

3. Select the checked Position from the Search menu to remove the dialog box.
4. Notebook.ini holds the Position status.



Editing Control Codes

1. Select Control Code from the Edit menu.
2. The Control Code menu item is checked when in the control code edit mode.    The 

unprintable one-byte control codes are translated into printable two-byte characters in 
the control code edit mode.    See the table below.    Horizontal tabs, carriage returns and 
line feeds are not converted.    When saving a document in the control code edit mode, 
control codes in the two-byte character form are converted to the one-byte form.    If a 
document is to contain the printable caret (^) character, enter a space or another 
character not in the Code column after every caret character where a translation is to be 
avoided.    Then exit the control code edit mode and remove the characters that were 
added to avoid translation.    The File Print command will send the form of the control 
codes seen on the monitor to the print spooler.    A lengthy translation may be aborted by
pressing the escape key and answering the message box.

Control Code Table
Value Code Mnemonic Description
00 ^@ NUL Spacing character is not used by Notebook.
01 ^A SOH Start of Heading.    Marks new data block or file.
02 ^B STX Start of Text.    Marks text following header.
03 ^C ETX End of text.    May begin error checking data.
04 ^D EOT End of transmission.    Sign-off code or the end of file.
05 ^E ENQ Enquiry.    Request for status from remote station.
06 ^F ACK Acknowledge.    Verifies the success of communications.
07 ^G BEL Bell.    Signal for attention.
08 ^H BS Backspace.
09 ^I HT Horizontal Tab.
10 ^J LF Line Feed.
11 ^K VT Vertical Tab.
12 ^L FF Form Feed.
13 ^M CR Carriage Return.
14 ^N SO Shift Out.    Change character set.
15 ^O SI Shift In.
16 ^P DLE Data Link Escape.    Modifies meaning of subsequent characters.
17 ^Q DC1 Device Control 1.    XON signal to remote station to transmit.
18 ^R DC2 Device Control 2.    General purpose toggle signal.
19 ^S DC3 Device Control 3.    XOFF signal to remote station not to 

transmit.
20 ^T DC4 Device Control 4.    General purpose toggle signal.
21 ^U NAK Negative Acknowledge.    Signals transmission failure.
22 ^V SYN Synchronous Idle.    Used between data blocks in synchronous 

communications.
23 ^W TB End of Transmission Block.
24 ^X CAN Cancel.    Signals error.
25 ^Y EM End of Medium.    Signals physical end of data source.
26 ^Z SUB Substitute.    Replaces invalid or non-displayable characters.
27 ^[ ESC Escape.    Marks following characters as a control sequence.
28 ^\ FS File Separator.    Marks file boundary.
29 ^] GS Group Separator.    Marks data group boundary.
30 ^^ RS Record Separator. Marks data record boundary.
31 ^_ US Unit Separator.    Marks data unit boundary.



Finding Text

1. Select Go To from the Search menu to display the dialog box.
2. Enter the text to find in the search combo box edit control.
3. An alternative to manually entering text into the search edit control is to select the 

appropriate text, if available in the main edit window, and use the Set Find push button 
control or Set Find from the Search menu or use the accelerator key to fill the search text
buffer.    The list box part of the search combo box holds previous search and replace 
entries of the current session.

4. Check the Case check box to perform a case sensitive search.
5. Select the Next or Back push buttons depending on the search direction.
6. Use the Next or Back push buttons, or use the Find Next or Find Prev    commands from 

the Search menu to continue a search.    Or use the accelerator keys to continue a 
search.

7. Searches begin at the current caret position.    The entire document will be scanned to 
find matching text.    If no match is found the speaker is beeped.

See...
Replacing Text.



Formatting Text

1. To insert a space, press the Spacebar.
2. To end a line, press Enter.
3. To indent a line or insert a tab, press Tab.
4. To insert a blank line, move the caret to the beginning of a line, press Enter.
5. To split a line, move the caret to the text to move to the next line, press Enter.
6. To join two lines, move the caret to the beginning of the line to move.    Press Backspace 

until the lines are joined.

On File Open or File Merge, if the number of characters on a line is greater than 1024, 
then a message box will appear.    If an affirmative response is entered, then carriage 
return line feed pairs will be inserted into the document.    The position dialog box shows 
the number of insertions during the process.    This process may be aborted by pressing 
the escape key and answering the message box.
Line lengths must be equal to or less than 1024 characters when scrolling from one field 
to the next.



Going To a Line

1. Select Go To from the Search menu to show the modeless dialog box.
2. Enter the number of the line to go to in the line number edit control.
3. Select the Next or Back push buttons or press Enter.
4. Going To a Line can be combined with Finding Text.    If the line number entry is greater 

than the actual number of lines in the document, the speaker is beeped.
5. The End push button will show the last line of the document in the edit window.



Inserting Date and Time

1. Select Date Format from the Edit menu to reveal the cascade menu.
2 Choose the desired format for the date and time strings.
3. Move the insertion point to the desired position.
3. Select Date, Time or Long Date from the Edit menu or use the accelerator keys.
4. Notebook.ini holds the date and time format status.

See...
Notebook Keys



Inserting a Page Break

Page Break
1. Move the insertion point to the desired position.
2. Select Page Break from the Edit menu.

Control Code
1. Select Control Code from the Edit menu.
2. Enter ^L on a line by itself where the break is desired.
3. Exit the control code mode.    If the screen font is ANSI the character is not visible.    If the 

screen font is OEM, then the character with the value of 12 is visible.

The Form Feed check box control in the Margins dialog box must be checked to allow the 
page break to be sent to the print spooler.

See...
Editing Control Codes
Setting Margins.



Merging a File

1. Move the caret to the position in the document where the file is to be placed.
2. Select Merge from the File menu to show the dialog box.
3. The file extension list box can quickly set the filespec for the files list box.
4. Select a file from the list box.    Or type the appropriate text into the edit control.
5. Select Merge.

The merge can be undone before any other changes are made to the document.

See...
Formatting Text.



Opening an Existing File

Open or Open History is selected from the File menu.

Open
1. Select Open to show the dialog box.
2. The file extension list box can quickly set the open filespec for the files list box.
3. Select a file from the list box.    Or type the appropriate text into the edit control.
4. Select Open.

Open History
1. Select Open History to reveal the cascade menu containing the names of the last four 

files opened.
2. Select one of the filenames to quickly open the file.

The filename of a text file as a command line parameter will open the file after Notebook 
initialization.    Win30 file associate requires appropriate modification to the Extensions 
section of the win.ini file.    Win31 and WinNT file associate requires appropriate entry 
into the File Associate dialog of the file manager.

If the opened file is not a text file, then the memory image is converted to a text format.  
A message box warns that File Save is disabled to protect the binary file format.    The 
text can be edited, sent to the clipboard and pasted into the destination text file.    This 
process allows extraction of text from word processor documents, spreadsheets, 
executables, etcetera.

Client drag functionality allows up to ten files to be opened per drop.    If the drop 
contains several files, then Notebook opens the first file dropped in the current instance, 
and spawns other instances to open the remaining files in the drop.

See...
Formatting Text
Running an Application.



Printing a Document

1. Select page settings from the Margins dialog box.
2. Select Print All from the File menu.
3. The current document is sent to the print spooler.    Printing may be aborted while the 

print file is being created.    Lines that do not fit inside the margins will be wrapped.    
When printing on both sides of the paper, first the odd numbered pages are printed.    
Next set the paper for printing the even numbered pages before answering the message 
box.    Laser printer users will have to manually collate the pages to print the even 
numbered pages.

See...
Notebook Keys
Setting Margins.



Printing Selected Text

1. Select page settings from the Margins dialog box.
2. Select text of the current document to be printed.
3. Select Print Selection from the File menu.
4. The selected text of the document is sent to the print spooler.    Printing may be aborted 

while the print file is being created.    Lines that do not fit inside the margins will be 
wrapped.

See...
Selecting Text
Setting Margins.



Replacing Text

To replace a single instance of selected text...
1. Select Go To from the Search menu to show the modeless dialog box.
2. Enter text into the replace combo box edit control.
3. An alternative to manually entering text into the replace edit control is to select the 

appropriate text, if available in the main edit window, and use the Set Replace push 
button control or Set Replace from the Search menu or use the accelerator key to fill the 
replace text buffer.    The list box part of the replace combo box holds previous search 
and replace entries of the current session.

4. Select text of the document with the keyboard or mouse.
5. Select the Replace push button, or select Replace from the Search menu or use the 

accelerator keys.
The replace command with the finding text features can selectively replace repeating 
words or small phrases.

To replace all occurrences of the search string with the replace string...
1. Select Go To from the Search menu to show the modeless dialog box.
2. Enter text into the search and into the replace combo box edit controls.
3. Select Next or Back to find an instance of the search string.
4. Select Replace All from the Search menu or use the accelerator key.

The replace all command shows a message box with the occurrence count and the string 
values.    If the message box receives an affirmative response, then the process of 
replacing all occurrences begins.    The position dialog box shows the number of 
occurrences left during the process.    The replace process may be aborted by pressing 
the escape key and answering the message box.    Upon completion the edit window 
shows the first line of the document.

See...
Finding Text
Notebook Keys.



Running an Application

1. Select Run from the File menu to show the dialog box.
2. The file extension list box can quickly set the run filespec for the files list box.
3. Select an application or associated file with the mouse by using the list boxes.    Or type 

the exact or appropriate text into the command line edit control.    If the application 
filename does not contain an extension, then .EXE is assumed.

4. Select Run or press the enter key.
This feature allows an efficient system interface and fast utilization of Notebook output 
with other applications.

See...
Opening an Existing File.



Saving Documents

To save an untitled document or rename the document...
1. Select Save As from the File menu to show the dialog box.
2. Enter a filename into the edit control.
3. Select Save.

To save a titled document ...
1. Note only documents that have been changed can be saved.
2. Select Save from the File menu.



Selecting a Screen Font

1. Select Fonts from the Edit menu to show the dialog box.
2. Select a font from the radio-button control choices.
3. Select Accept.
4. Notebook.ini holds the screen Font status.

See...
Setting Tab Spacing.



Selecting Text

1. Move the caret with the mouse pointer to the beginning or end of the text to select.
2. Hold down the mouse button while moving the pointer to highlight the text.
3. Release the mouse button when the correct amount of text is highlighted.

To select the entire document choose Select All from the Edit menu.

See...
Notebook Keys.



Setting Case

1. Select the text desired where case is to be modified.
2. Select Set Case from the Edit menu to reveal the four ways available to modify the case.
3. The choices to modify the case of the selected text are all lower case, all upper case, the 

first letter of each word upper case and the rest lower case, and the first letter of each 
sentence upper case and the rest lower case.

4. The case changes can be undone.

See...
Selecting Text.



Setting Go To Dialog Mode

1. Determine if Go To dialog box visibility is unnecessary for most find and replace 
operations.

2. Select Dialog Mode from the Search menu to destroy the Go To dialog after a successful 
search.

3. Notebook.ini holds the Dialog Mode status.

See...
Finding Text.



Setting Initial Window Size

1. Position the main window to the desired screen size and location.
2. Select Initial Size from the Edit menu to record the size and position of the main window.  

The next time the program is started these settings determine the initial size and 
position of the main window.    Initial Size command will be checked when set.

3. If Initial Size is set when selected, then a message box is shown to allow the user to clear
the initial size setting.    A new initial size can be set after the old one is cleared.

4. Notebook.ini holds the initial window size and position.

See...
Setting Window Width.



Setting Margins

1. Select Margins from the File menu to show the dialog box.
2. The check box control for the margin must be checked to allow the change.
3. Select a margin size from the list box control.
4. The header can be customized by typing into the title edit control.    The default header is

the document filename.
5. To allow the header or the page number as a footer to be sent to the print spooler, check 

the appropriate check box.
6. Select the Form Feed check box to allow page breaks.
7. Select the 2-Sided check box to print on both sides.
8. Choose Accept.
9. Notebook.ini holds the margin size and header, footer and formfeed status.

See...
Inserting a Page Break
Printing a Document
Setting Printers.



Setting Printers

1. Select Printer Setup from the File menu to show the dialog box.
2. The list box control displays all the installed printers with the default printer selected.
3. Select the desired printer from the list box control.
4. The printer driver settings can be modified by pressing the Setup push button control.
5. The selected printer becomes the default printer by pressing the OK push button.
6. Win.ini holds the default printer status.

See...
Setting Margins.



Setting Tab Spacing

1. Select Fonts from the Edit menu to show the dialog box.
2. Select a tab-stop spacing from the list box control choices.
3. Select Accept.

The tab-stop spacing is also used to format the document sent to the print spooler for 
hardcopy.    Notebook.ini holds the tab spacing value.

See...
Selecting a Screen Font.



Setting Window Width

Set Window Width to Printer Page Width
1. Set margins as necessary.
2. Choose a fixed font to accurately display the printer setting.
3. Select Set Width from the Edit menu.

Set Characters Per Line
1. Select Fonts from the Edit menu to show the Fonts dialog.
2. Enter the desired number in the Characters/Line edit control.
3. Enter a zero to set the window width to the printer page width.
4. Select Accept.

See...
Selecting a Screen Font
Setting Initial Window Size
Setting Margins.



Showing Date and Time

1. Select Date Format from the Edit menu to reveal the cascade menu.
2. Select Show Date or Show Time from the Date Format menu to display date or time in 

the title bar.    Accelerator keys can toggle the date and time display as desired.
3. Notebook.ini holds the date and time display status.

See...
Notebook Keys.



Undoing Edits

1. Verify that Undo from the Edit menu is enabled.
2. If enabled, then select Undo from the Edit menu to undo the last edit.
3. Huge edits can be undone before any other changes are made to the document.



Using the Bookmark

1. Select Bookmark from the Search menu to set the bookmark.    Bookmark command will 
be checked when set.    Caret position is the offset stored as a bookmark.

2. If Bookmark is set when selected, then a message box is shown to allow the user to clear
the bookmark.    A new bookmark can be set after the old one is cleared.

3. Select Go To from the Search menu to show the modeless dialog box.
4. Select the Bookmark push button control.
5. The edit control will show the offset into the document that was stored when the 

bookmark was set.    The bookmark is a number only.    It is not associated with any 
particular document.    If the bookmark is not set, then selecting the Bookmark push 
button will show the beginning of the document which is zero offset.    Notebook.ini holds 
the Bookmark status.



Wrapping Text

1. Choose unchecked Word Wrap from the Edit menu.
2. The edit control is drawn with no horizontal scroll bar.    The Word Wrap menu item is 

checked when in the word wrap mode.
3. Text will be broken at a space character.
4. Notebook.ini holds word wrap status.

A word wrapped edit control in Win30 needs twice as much local buffer memory when 
Notebook is    minimized.    Therefore page or field size is nominally 16 thousand bytes in 
word wrap mode.    This defect is fixed in Win31 which allows the page size to remain 32 
kilobytes whether or not the edit control is wrapped.    The edit control is not re-sized if 
the main window is minimized to avoid the defect of extra time (a ten to twenty second 
deadlock) involved in minimizing a word wrapped edit control.



How to Order

The purchase of the single-user shareware version of Notebook is $10 US.    Credit 
card purchase of a single-user license is $16 US.    Messages may be sent to the author by 
way of CompuServe to number 70134,3016.    Contact the author by the U. S. Postal Service 
at the following address:

Mark Berlinger
1317 N. San Fernando Blvd. #133

Burbank, CA    91504

Site and corporate licenses are available.    The following is a table of license fees:

Number of 
Users

License Fee

1 - 9 $10 per user
10 $50 ($50 price break)

11 - 24 $50 + $5 per user
25 $100 ($25 price break)

26 - 49 $100 + $4 per user
50 $175 ($25 price break)

51 - 99 $175 + $3 per user
100+ $300 ($25 price break)

Site and Corporate License 
Information

Add 10% for credit card orders.    To order by credit card (only) contact:
Public (software) Library with your MC, Visa, AmEx or Discover card by calling 800-2424-
PsL or 713-524-6394 or by FAX to 713-524-6398 or by CompuServe to 71355,470 or by mail 
to PsL, P.O.Box 35705, Houston, TX 77235-5705.    Please include your address with all 
orders.    These numbers are for ordering only.    For information about dealer pricing, volume 
discounts, site licensing or technical information contact the author.

Periodically check the CompuServe WINADV forum for updates to the shareware 
version of Notebook.    The optional diskette service is an additional $6 or $8 overseas cash 
or check to the author for shipping and handling.    By credit card from PsL the diskette 
service is $4 S&H or $6 S&H overseas.    As always, constructive criticism is appreciated.

Notebook for the Windows New Technology operating system is available in the 
CompuServe WINNT forum.    Notebook NT has the functionality of Notebook for Windows 
3.1.    The single-user registration fee for both Notebook for Windows NT and Windows 3.1 is 
twenty dollars US or $26 by credit card.    If you are already registered as a Notebook for 
Win31 user, then the Notebook NT registration fee is ten dollars US or sixteen dollars by 
credit card.





Notebook Keys

Choose from the following list to review the keys used in Notebook.

Cursor Movement Keys
Dialog Box Keys
Editing Keys
Function Keys
Menu Keys
System Keys
Text Selection Keys
Window Keys



Cursor Movement Keys
The mouse pointer is called the cursor.    The text insertion point is called the caret.

Key(s) Function

DIRECTION key Moves the caret left, right, up, or down in a field.
Ctrl+Home Moves to the beginning of a field.
Ctrl+End Moves to the end of a field.
Home Moves to the beginning of a line.
End Moves to the end of a line.
Ctrl+Left Arrow Moves left one word.
Ctrl+Right Arrow Moves right one word.
Page Up Moves up in a field, one screen at a time.
Page Down Moves down in a field, one screen at a time.
Ctrl+Page Up Moves up one field at a time.
Ctrl+Page Down Moves down one field at a time.

See...
Formatting Text.



Dialog Box Keys

Key(s) Function

Tab Moves from field to field (left to right and top to bottom).
Shift+Tab Moves from field to field in reverse order.
Alt+letter Moves to the option or group whose underlined letter matches 

the one you type.
DIRECTION key Moves from option to option within a group of options.
Enter Executes a command button.

Or, chooses the selected item in a list box and executes the 
command.

Esc Closes a dialog box without completing the command. (Same as
Cancel)

Alt+Down Arrow Opens a drop-down list box.
Alt+Up or Down Arrow Selects item in a drop-down list box.
Spacebar Cancels a selection in a list box.

Selects or clears a check box.
Ctrl+SLASH Selects all the items in a list box.
Ctrl+BACKSLASH Cancels all selections except the current selection.
Shift+DIRECTION key Extends selection in a text box.
Shift+Home Extends selection to first character in a text box.
Shift+End Extends selection to last character in a text box



Editing Keys

Key(s) Function

Backspace Delete the character to the left of the caret.    Or, delete 
selected text.

Alt+Backspace Undo the previous edit.
Shift+Delete Cut selected text from the edit window and move it to the 

clipboard.
Ctrl+Insert Copy selected text from the edit window and move it to the 

clipboard.
Shift+Insert Paste text from the clipboard to the caret position.
Alt+Insert Replace selected text with text from the dialog box replace edit 

control by way of the clipboard.
Delete Delete the character to the right of the caret or delete selected 

text.
Ctrl+Delete Deletes selected text or all the selected text of a huge 

document.

See...
Copying, Cutting and Pasting Text
Deleting Text
Selecting Text.



Function Keys

Key(s) Function

F1 Runs the help engine and displays the Help Index for Notebook. 
If the Help window is already open, pressing F1 displays the 
"Using Windows Help" topics.

F2 If there is text in the edit window, then the text is sent to the 
print spooler.

F3 If search text has been entered into the Go To dialog box, a 
search for the next occurrence of the string is performed.

F4 If search text has been entered into the Go To dialog box, a 
search for the previous occurrence of the string is performed.

F5 Inserts the real time clock date into the document.
Shift+F5 Date insertion format is set to D-M-Y.
Ctrl+F5 Date insertion format is set to M/D/Y.
F6 Inserts the real time clock time into the document.
Shift+F6 Time insertion format is set to H:M.
Ctrl+F6 Time insertion format is set to H:M:S.
Shift+F7 Inserts the unabridged real time clock date into the document.
Shift+F8 Shows the date in the title bar.
Shift+F9 Shows the time in the title bar.
F7 If search and replace text have been entered into the Go To 

dialog box, the replacement of all occurrences of the search 
string with the replace string is performed.

F8 If text has been selected in the main client area, then the 
selected text is sent to the Find Text edit control buffer of the Go
To dialog box.

F9 If text has been selected in the main client area, then the 
selected text is sent to the Replace Text edit control buffer of 
the Go To dialog box.

See...
Finding Text
Inserting Date and Time
Printing a Document
Replacing Text
Showing Date and Time.



Menu Keys

Key(s) Function

Alt Selects the first menu on the menu bar.
Letter key Chooses the menu, or menu item, whose underlined letter 

matches the one you type.
Alt+letter key Pulls down the menu whose underlined letter matches the one 

you type.
Left or Right Arrow Moves among menus.
Up or Down Arrow Moves among menu items.
Enter Chooses the selected menu item.



System Keys

The following keys can be used from any window.
Key(s) Function

Ctrl+Esc Switches to the Task List.
Alt+Esc Switches to the next application window or minimized icon, 

including full-screen programs.
Alt+Tab Switches to the next application window, restoring applications 

that are running as icons.
Alt+Print Screen Copies the entire screen to Clipboard.
Ctrl+F4 Closes the active window.



Text Selection Keys

Key(s) Function

Shift+Left or Right Arrow Selects text one character at a time to the left or right.
Shift+Down or Up Selects one line of text up or down.
Shift+End Selects text to the end of the line.
Shift+Home Selects text to the beginning of the line.
Shift+Page Down Selects text down one window.

Or, cancels the selection if the next window is already 
selected.

Shift+Page Up Selects text up one window.
Or, cancels the selection if the previous window is already 
selected.

Ctrl+Shift+Left or Right Arrow Selects text to the next or previous word.
Ctrl+Shift+Up or Down Arrow Selects text to the beginning (UP ARROW) or end (DOWN

ARROW) of the paragraph.
Ctrl+Shift+End Selects text to the end of the field.
Ctrl+Shift+Home Selects text to the beginning of the field.

See...
Selecting Text.



Window Keys

Key(s) Function

ALT+Spacebar Opens the Control menu for an application window.
ALT+Hyphen Opens the Control menu for a document window.
Alt+F4 Closes a window.
Alt+Esc Switches to the next application window or minimized icon, 

including full-screen programs.
Alt+Tab Switches to the next application window, restoring applications 

that are running as icons.
Alt+Enter Switches a non-Windows application between running in a 

window and running full screen.
DIRECTION key Moves a window when you have chosen Move from the Control 

menu.
Or, changes the size of a window when you have chosen Size 
from the Control menu.





Accelerator Keys

Accelerator keys are shortcut keys that let the user choose a command from a menu by 
using a single key stroke.



Associate

To identify a filename extension as belonging to a particular application, so that the 
requested opening of any file with that extension will immediately run the particular 
application and open the requested file.



Bitmap

A bitmap is an image formed by a pattern of bits.



Caret

The caret is the text insertion point of an edit control.    It is represented by a blinking vertical
bar.



Clipboard

The clipboard is the main data-exchange feature of Windows.    It is a common area to store 
data handles by which applications can exchange formatted data.



Control

A control is a predefined child window that carries out a specific input or output.



Control Code

ASCII control codes are used in communications or to operate printers and other devices.



Cursor

The cursor is a special bitmap that shows the user where actions initiated with the mouse 
will take place.    The cursor can be an arrow, hourglass, I-beam, cross-hair or other custom 
shape.



Dialog Boxes

A dialog box is a temporary pop-up window that is displayed to allow the user to supply 
more information to direct the action of a command.    A dialog box contains one or more 
controls for simple input or output.    The two types of dialog boxes are modal and modeless.
A modal dialog box temporarily disables the parent window to force the user to complete 
the requested action before returning control to the parent window.    A modal dialog box 
starts its own message loop without returning to the WinMain function.
A modeless dialog box does not disable the parent window.    The user can work in the 
parent window while the modeless dialog box is displayed.    A modeless dialog box receives 
messages through the message loop in the WinMain function.



Field

A field is a memory resouce with application determined content and size.






